Echolot
Erste Schritte

Das Fenster

Ein Rundgang durch das Echolot-Fenster, seine Seitenleiste, Seiten, Tabs und Panels, mit den Tastenkürzeln für jedes.

Jeder Arbeitsbereich öffnet sich in einem eigenen Fenster. Das Fenster hat zwei Teile: die Seitenleiste links und das Inhaltspanel rechts, das unter seinem Seitenkopf jeweils eine Seite zeigt.

Ein Echolot-Fenster: die Seitenleiste mit Start, Suchen, der Modulauswahl und dem Anfragenbaum sowie rechts eine Anfrage mit ihrer Antwort

Das Willkommensfenster

Ist kein Arbeitsbereichsfenster geöffnet, zeigt Echolot sein Willkommensfenster: Neuer Arbeitsbereich …, Arbeitsbereich öffnen …, Beispiele öffnen und deine letzten Arbeitsbereiche. Unter dem Namen steht die Version mit einem Link Neuigkeiten. Arbeitsbereiche, die du aus dem Finder öffnest (ein Doppelklick auf einen .echolot-Ordner), gehen direkt in ein Arbeitsbereichsfenster.

Die Seitenleiste

Von oben nach unten:

  • Start und Suchen, neben den Knöpfen des Fensters. Start (⇧⌘H) ist die Übersicht des Arbeitsbereichs: Zahlen zu Anfragen, Ordnern, Umgebungen, Variablen und Prüfungen, deine letzten Anfragen, die neuesten Antworten, der Stand der Tests und die Umgebungen, darüber die Karte Sonar, die jedes Senden der letzten Stunde, des letzten Tages, der letzten Woche oder des letzten Monats danach zeichnet, wie lange es dauerte. Siehe Start und Sonar. Suchen öffnet die Befehlspalette (⌘K).
  • Die Modulauswahl, die bestimmt, was die Seitenleiste auflistet. Jedes Modul hat eine eigene Seite.
  • Die Listen des Moduls.
  • Die Arbeitsbereichsauswahl am Fuß.

⌘B (Ansicht › Seitenleiste ausblenden) blendet die Seitenleiste aus und ein. Ziehe ihren rechten Rand, um sie breiter oder schmaler zu machen.

Module

ModulTastenkürzelDie Seitenleiste listetMehr dazu
Anfragen⌘1Tests und Ausführung mit ihrem Stand, dann deine Ordner und AnfragenAnfragen
MCP-Server⌘2Die MCP-Server des ArbeitsbereichsMCP-Server
Specs⌘3OpenAPI-Dokumente und .proto-DateienSpecs
Mocks⌘4Mock-ServerMocks
Flows⌘5FlowsFlows

Wechselst du zu einem Modul, kehrst du zu dem zurück, was es zuletzt zeigte. Ein Klick auf eine Zeile in einer Liste öffnet sie auf der Seite des Moduls.

Der Anfragenbaum

Im Modul „Anfragen“ fügt der Knopf + neben Anfragen eine Anfrage beliebiger Art hinzu (HTTP, GraphQL, WebSocket, Socket.IO, MQTT, gRPC oder einen MCP-Aufruf), einen Ordner oder Importe und Exporte. Ordner- und Anfragezeilen haben eigene Menüs (Rechtsklick) mit Neue Anfrage, Neuer Ordner, Ordnereinstellungen …, Umbenennen, Duplizieren, Nach oben, Nach unten, Im Finder anzeigen und In den Papierkorb legen ….

  • Ziehe Zeilen, um sie neu zu ordnen oder in Ordner zu verschieben. Dort, wo sie landen, öffnet sich eine Lücke, und wenn du über einem geschlossenen Ordner verweilst, öffnet er sich.
  • Wähle mehrere Zeilen mit ⌘ oder ⇧ und klicke mit der rechten Maustaste für N Objekte ausführen, N Anfragen bearbeiten …, Neuer Ordner mit N Objekten, Bewegen nach und N Objekte in den Papierkorb legen ….
  • Setze einen cURL-Befehl, eine Collection oder eine Spec in die Seitenleiste ein, um sie zu importieren, oder ziehe Dateien auf das Fenster.
  • Bearbeiten › Duplizieren (⌘D) und Bearbeiten › Umbenennen wirken auf die ausgewählte Zeile.
  • Ein Punkt neben einer Anfrage heißt, dass sie Änderungen hat, die noch nicht geschrieben sind.
  • Ein Warnzeichen neben einer Anfrage heißt, dass ihr letztes Senden fehlschlug: keine Antwort, ein Status ab 400 oder ein gRPC-Status außer OK. Halte den Zeiger darauf, um zu lesen, was schiefging. Ein späterer Erfolg löscht es.

Nichts wird ohne Nachfrage gelöscht, und gelöschte Objekte kommen in den Papierkorb. Mehr unter Ordner.

Die Arbeitsbereichsauswahl

Der Name des Arbeitsbereichs, darunter sein Sicherungsstatus: Alles gesichert, Wird gesichert … oder Sichern fehlgeschlagen. Klicke darauf für deine letzten Arbeitsbereiche, Neuer Arbeitsbereich …, Arbeitsbereich öffnen …, Arbeitsbereichseinstellungen … und Im Finder anzeigen. Datei › Arbeitsbereich wechseln … (⌘P) listet stattdessen die letzten Arbeitsbereiche in einem schwebenden Panel auf; tippe zum Filtern, Return öffnet.

Der Seitenkopf

Der Streifen oben im Inhaltspanel benennt die Seite. Bei einer Anfrage zeigt er die Ordner und den Namen der Anfrage. Rechts liegen die Knöpfe des Fensters:

KnopfWas er tut
Neuigkeiten (Funkeln)Erscheint nach einem Update mit den neuen Versionshinweisen.
VerlaufJede Antwort, mit dem Absender: du, ein Durchlauf oder ein Agent (⌘Y). Siehe Verlauf.
AgentenLässt externe KI-Agenten diesen Arbeitsbereich über Echolots MCP-Server nutzen. Siehe Agenten.
UmgebungWählt die aktive Umgebung oder Keine Umgebung; Umgebungen verwalten … öffnet die Seite „Umgebungen“. Eine geschützte Umgebung zeigt ein Schild. Siehe Umgebungen.
LayoutBei einer Anfrage: nebeneinander oder untereinander. Siehe Bereiche.
EditorBei einer Spec: der visuelle oder der Texteditor.
Assistent (Zauberstab)Öffnet den Assistenten (⌘J).

Der Seitenkopf ersetzt eine Titelleiste: Ziehe ihn, um das Fenster zu bewegen, und doppelklicke darauf, um das zu tun, was du unter Systemeinstellungen › Schreibtisch & Dock für eine Titelleiste festgelegt hast (standardmäßig Zoomen).

Seiten

Außer den Modulseiten öffnet das Menü Ansicht diese:

SeiteTastenkürzel
Start⇧⌘H
Tests: die Prüfungen jeder Anfrage⌥⌘T
Ausführung: Ordner oder den Arbeitsbereich ausführen⌥⌘R
Umgebungen⌥⌘E
Verlauf⌘Y

Ansicht › Variablen einblenden (⌥⌘V) öffnet das Variablen-Panel: jede Variable im ganzen Arbeitsbereich, in seinen Ordnern und Umgebungen, mit markiertem verwendetem Wert und maskierten Secrets. Hefte es als Spalte neben den Inhalt oder lass es schweben.

Hilfe › Hilfe zu dieser Seite öffnet die Seite dieser Doku über die Seite, auf der du bist.

Tabs

Anfragen, die du öffnest, werden zu Tabs über der Anfrageseite.

AktionTastenkürzel
Tab schließen⌘W
Fenster schließen⇧⌘W
Tabs › Nächsten Tab anzeigen⇧⌘]
Tabs › Vorherigen Tab anzeigen⇧⌘[
Tabs › Geschlossenen Tab wieder öffnen⇧⌘T

⌘W schließt den Tab auf dem Bildschirm, nie das Fenster, wie in einem Browser.

Die Anfrageseite

Die Anfrageseite hat zwei Bereiche: den Anfrage-Editor und die Antwort.

  • Der Anfragekopf ganz oben: die Methode, die Adresse und Senden (⌘R oder ⌘↩). Ist eine geschützte Umgebung aktiv, steht auf Senden der Text An Umgebung senden … und fragt zuerst nach. Sitzungen (WebSocket, Socket.IO, MQTT) haben stattdessen Verbinden und Trennen.
  • Die Tabs des Editors hängen von der Art der Anfrage ab. Eine HTTP-Anfrage hat Doku, Header, Parameter, Body, Auth, Vars, Tests, Skripte und Einstellungen. Siehe Anfragen.
  • Die Tabs der Antwort: Body, Tests, Header, Cookies, Roh, Hex und Übertragung, dazu Konsole, wenn Skripte liefen, Ereignisse bei einem Stream, Nachrichten bei einer Sitzung und Schema bei GraphQL. Siehe Antworten.

Bereichslayouts

Die Bereiche liegen Nebeneinander oder Untereinander (die Antwort unten). Wähle mit dem Knopf Layout im Seitenkopf oder mit Ansicht › Bereiche. Jede Art von Anfrage behält ihr eigenes Layout und ihre eigene Position des Trenners, nur auf diesem Mac: Eine HTTP-Anfrage kann nebeneinander liegen, während WebSocket-Anfragen untereinander liegen. Ziehe den Trenner, um die Größe zu ändern; Ansicht › Bereiche › Bereichsgrößen zurücksetzen stellt jede Art wieder her. Ist das Fenster für „Nebeneinander“ zu schmal, liegen die Bereiche untereinander, bis wieder Platz ist.

Das Menü „Anfrage“

EintragTastenkürzel
Senden⌘R
Abbrechen⌘.
Als cURL kopieren⌥⌘C
Code erzeugen …⌥⌘G
Austausch als HAR exportieren …
Im Body suchen⌘F
Befehlspalette …⌘K

Ansicht › Code vergrößern (⌘+), Code verkleinern (⌘-) und Code in Originalgröße (⌘0) ändern die Größe von Antwort-Bodys, Bäumen und Code-Editoren. Ansicht › Lange Zeilen umbrechen bricht sie um.

Die Befehlspalette

⌘K oder Suchen in der Seitenleiste öffnet eine Suche über den ganzen Arbeitsbereich. Tippe ein paar Buchstaben und drücke Return auf einem Ergebnis:

  • Anfragen, mit ihrem Ordner und ihrer Adresse.
  • Aktionen: Gehe zu einer beliebigen Seite, Neue Anfrage und die anderen Arten, Neuer Ordner, Neue Spec, Importieren …, Arbeitsbereich exportieren …, Arbeitsbereichseinstellungen …, Variablen einblenden, Arbeitsbereich ausführen und bei einer Anfrage Senden, Als cURL kopieren, Code erzeugen …, Layout umschalten und Bereichsgrößen zurücksetzen.
  • Umgebungen: Umgebung verwenden wechselt zu ihr.
  • Antworten: Ab drei Zeichen durchsucht sie auch die Antworten im Verlauf.
Die Befehlspalette über einem Arbeitsbereich, mit Anfragen, Aktionen und Umgebungen, die zum getippten Text passen

Das Assistent-Panel

⌘J (Ansicht › Assistent einblenden) oder der Zauberstab am Ende des Seitenkopfs öffnet den Assistenten rechts auf jeder Seite. Er ist der in Echolot eingebaute KI-Agent: Er kann Anfragen senden, Prüfungen schreiben und Flows, Specs und Mocks bauen und fragt dich, bevor er etwas ändert. Richte ein Modell unter Einstellungen › Assistent ein. Siehe Assistent.

Echo

Echo ist ein kleiner Statusbildschirm in der Mitte des Seitenkopfs. Er zeigt, was gerade los ist: Sendungen und ihre Zeiten, Fehler, Durchläufe, Flows, Mocks, Agenten und die aktive Umgebung, ab und zu mit einem Witz. Klicke darauf für einen Bericht der Sitzung. Standardmäßig ist er aus: Schalte ihn unter Einstellungen › Allgemein › Echo mit Statusbildschirm von Echo im Seitenkopf anzeigen ein. Siehe Echo.

Einstellungen

Echolot › Einstellungen … (⌘,) hat die Bereiche Allgemein, Netzwerk, Speicher, Assistent, Agenten, Datenschutz und Über sowie ein Suchfeld, das eine Einstellung nach ihrem Namen findet. Siehe Einstellungen. Einstellungen für einen Arbeitsbereich oder Ordner liegen unter Arbeitsbereichseinstellungen … (Auth, Variablen, Skripte, Agenten, Proxy, Zertifikate) und Ordnereinstellungen … (Auth, Variablen, Skripte, Doku).

Alle Tastenkürzel stehen unter Tastenkürzel.

Auf dieser Seite